High severity · published Oct 27, 2026
CVE-2026-114598
Access of resource using incompatible type ('type confusion') in EPICS Base
New
7.5
CVSS
–
EPSS
No
On KEV
Description
In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
EB
EPICS Base · The EPICS Community
through 7.0.10 · source: vendor
In the news
VulnerabilityCritical
EPICS Base
View CSAF
Summary
Successful exploitation of these vulnerabilities could allow an attacker to cause a denial-of-service condition, corrupt memory, disclose sensitive information, or potentially execute arbitrary code.
The following versions of EPICS Base are affected:
EPICS Base release <=7.0.10 (CVE-2026-114595, CVE-2026-114596, CVE-2026-114597, CVE-2026-114598)
CVSS
Vendor
Equipment
v3 9.8
The EPICS Community
EPICS Base release
3 Vulnerabilities
Integer Overflow or Wraparound, Improper Handling of Length Parameter Inconsistency, Access of Resource Using Incompatible Type ('Type Confusion')
Background
Critical Infrastructure Sectors: Critical Manufacturing
Countries/Areas Deployed: Worldwide
Company Headquarters Location: Global
Vulnerabilities
Expand All +
CVE-2026-114595
In EPICS Base release 7.0.10 and prior, an integer overflow in network request processing can cause memory to be allocated with an incorrect size. Subsequent handling of attacker supplied data may result in memory corruption, denial of service, or potential remote code execution.
Read More
1 Affected Product
The EPICS Community EPICS Base release: <=7.0.10
Product Status: known_affected
Remediations
Mitigation The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, u...
Oct 27, 2026·CISA Advisories
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-114598
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-114598
www.cisa.gov
https://www.cisa.gov/news-events/ics-advisories/icsa-26-300-01
More from EPICS Base
9.8
CVE-2026-114595
Integer overflow or wraparound in EPICS Base
8.2
CVE-2026-114596
Integer overflow or wraparound in EPICS Base
7.5
CVE-2026-114597
Improper handling of length parameter inconsistency in EPICS Base
