High severity · published Jun 5, 2026
CVE-2026-11400
Privilege Escalation in AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL
8.0
CVSS
0.5%
EPSS
No
On KEV
Description
An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper.
To remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 42% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
AWS Advanced JDBC Wrapper · AWS
3.0.0 before 4.0.1 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-11400
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-11400
aws.amazon.com
https://aws.amazon.com/security/security-bulletins/2026-039-aws/
github.com
https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/4.0.1
github.com
https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-mhww-p97m-3368
More from AWS Advanced JDBC Wrapper
8.8
CVE-2026-14265
RCE via Deserialization in AWS Advanced JDBC Wrapper
5.9
CVE-2026-18061
Improper Restriction of XML External Entity References in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin
