High severity · published Oct 12, 2026
CVE-2026-108836
Ollama Pull API name.go IsValid server-side request forgery
7.3
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability has been found in Ollama up to 0.34.1. The affected element is the function IsValid of the file types/model/name.go of the component Pull API. The manipulation leads to server-side request forgery. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.34.2 is sufficient to fix this issue. The identifier of the patch is dfabde4539e42ba1e1eab50a3a50b88aea7958a0. It is suggested to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 40% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OL
Ollama · Ollama
0.34.0; 0.34.1 · source: vendor
Affected product
OL
Ollama
Ollama
More from Ollama
9.8
CVE-2026-42249
Remote Code Execution in Ollama via Update Mechanism
9.8
CVE-2026-42248
Missing Signature Verification for Updates in Ollama
9.8
CVE-2025-63389
A critical authentication bypass vulnerability exists in Ollama platform's API endpoints in versions prior to and including v0.12.3
9.4
CVE-2026-103663
Path Traversal leading to Remote Code Execution in Ollama
9.1
CVE-2026-7482
Ollama heap out-of-bounds read in GGUF tensor parsing leaks server process memory to unauthenticated remote attackers