High severity · published Oct 16, 2026
CVE-2026-108374
ERPNext: Unauthorised status modification due to missing validation
7.7
CVSS
0.2%
EPSS
No
On KEV
Description
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.121.0 and 16.34.0, certain endpoints for status modification fail to enforce proper authorization checks. A low-privileged authenticated user can invoke state-changing whitelisted methods without required write, submit, cancel, document, or role checks. This allows the user to modify data beyond the user's permitted role. This issue is fixed in versions 15.121.0 and 16.34.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 15% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ER
erpnext · frappe
< 15.121.0; >= 16.0.0, < 16.34.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-108374
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-108374
github.com
https://github.com/frappe/erpnext/commit/547d82da563380a0644919173e00d0205f986d89
github.com
https://github.com/frappe/erpnext/commit/86e94803629ea5668c2fc2d18afb5ca59fe2cf03
github.com
https://github.com/frappe/erpnext/commit/a20fc4f9317ecc7d262625aea680c9a0cda98cef
github.com
https://github.com/frappe/erpnext/releases/tag/v15.121.0
github.com
https://github.com/frappe/erpnext/releases/tag/v16.34.0
github.com
https://github.com/frappe/erpnext/security/advisories/GHSA-5wpj-6rvp-9ff7
More from erpnext
9.9
CVE-2026-65974
ERPNext: Server-Side Template Injection leading to Remote Code Execution
9.9
CVE-2026-72911
ERPNext: Possibility of server-side template injection due to missing validation
9.9
CVE-2026-44442
ERPNext: Unauthorised Document modification due to missing validation
9.8
CVE-2026-38431
ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI)
9.6
CVE-2025-67289
An arbitrary file upload vulnerability in the Attachments module of Frappe Framework v15.89.0 allows attackers to execute arbitrary code via uploading a crafted XML file
