High severity · published Aug 10, 2025
CVE-2025-8801
A vulnerability was found in Open5GS up to 2.7.5
7.5
CVSS
0.8%
EPSS
No
On KEV
Description
A vulnerability was found in Open5GS up to 2.7.5. This affects the function gmm_state_exception of the file src/amf/gmm-sm.c of the component AMF. The manipulation leads to denial of service. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.7.6 is able to address this issue. The identifier of the patch is f47f2bd4f7274295c5fbb19e2f806753d183d09a. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 55% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OP
Open5gs · Open5gs
before 2.7.6 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-8801
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-8801
github.com
https://github.com/ZHENGHAOHELLO/BugReport/blob/main/CVE-2025-8801
Patch
https://github.com/open5gs/open5gs/commit/f47f2bd4f7274295c5fbb19e2f806753d183d09a
Issue Tracking
https://github.com/open5gs/open5gs/issues/3977
Issue Tracking
https://github.com/open5gs/open5gs/issues/3977#issuecomment-3052575886
Release Notes
https://github.com/open5gs/open5gs/releases/tag/v2.7.6
Exploit
https://github.com/user-attachments/files/21095572/nudm-sdm.zip
More from Open5gs
9.8
CVE-2026-2522
Open5GS MME esm-build.c memory corruption
9.8
CVE-2026-2521
Open5GS SGW-C sgwc_s5c_handle_create_session_response memory corruption
9.8
CVE-2024-40130
open5gs v2.6.4 is vulnerable to Buffer Overflow
9.8
CVE-2024-40129
Open5GS v2.6.4 is vulnerable to Buffer Overflow
9.8
CVE-2021-28122
A request-validation issue was discovered in Open5GS 2.1.3 through 2.2.x before 2.2.1
