Critical severity · published Dec 23, 2025
CVE-2025-68615
net-snmp is a SNMP application library, tools and daemon
9.8
CVSS
42.4%
EPSS
No
On KEV
Description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)42.4% · higher than 99% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
11.0 · source: NVD
NE
Net-snmp · Net-snmp
before 5.9.5; 5.10 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-68615
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-68615
Vendor Advisory
https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq
Mailing List
http://www.openwall.com/lists/oss-security/2026/01/09/2
Mailing List
https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html
Exploit
https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp
Mitigation
https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
