Medium severity · published Dec 30, 2025
CVE-2025-67746
Composer vulnerable to ANSI sequence injection
4.3
CVSS
0.5%
EPSS
No
On KEV
Description
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 39% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CO
composer · composer
>= 2.0, < 2.2.26; >= 2.3, < 2.9.3 · source: vendor, NVD
Affected product
CO
composer
composer
More from composer
8.8
CVE-2026-40261
Composer has Command Injection via Malicious Perforce Reference
7.8
CVE-2026-40176
Composer is vulnerable to Command Injection via Malicious Perforce Repository
7.7
CVE-2026-84361
Composer: Perforce source URL permits P4PORT `rsh:` command execution
7.5
CVE-2026-45793
Composer: Github Actions issued GITHUB_TOKEN disclosure in GitHub Actions logs
7.0
CVE-2026-59948
Composer: Arbitrary file write outside vendor via malicious transitive package name