Medium severity · published Dec 2, 2025
CVE-2025-65105
Apptainer ineffective application of selinux and apparmor --security options
5.3
CVSS
0.2%
EPSS
No
On KEV
Description
Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 14% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AP
apptainer · apptainer
< 1.4.5 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-65105
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-65105
Patch
https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981
Patch
https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2
Issue Tracking
https://github.com/apptainer/apptainer/pull/3226
Patch
https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j
Not Applicable
https://github.com/opencontainers/runc/security/advisories/GHSA-cgrx-mc8f-2prm
Not Applicable
https://github.com/sylabs/singularity/security/advisories/GHSA-wwrx-w7c9-rf87
More from apptainer
4.8
CVE-2026-48785
Apptainer: Incorrect path matching for 'limit container paths' directive
