High severity · published Oct 2, 2025
CVE-2025-61735
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin
7.3
CVSS
1%
EPSS
No
On KEV
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 64% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
KY
Kylin · Apache
4.0.0 before 5.0.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-61735
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-61735
Issue Tracking
https://lists.apache.org/thread/yscobmx869zvprsykb94r24jtmb58ckh
www.openwall.com
http://www.openwall.com/lists/oss-security/2025/09/30/9
More from Kylin
8.8
CVE-2020-1956
Apache Kylin OS Command Injection Vulnerability
9.8
CVE-2026-62392
Apache Kylin: OS Command Injection via Async Query API
9.8
CVE-2026-62390
Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
9.8
CVE-2022-44621
Diagnosis Controller miss parameter validation, so user may attacked by command injection via HTTP Request
9.8
CVE-2022-24697
Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters
