High severity · published Dec 11, 2025
CVE-2025-59802
Foxit PDF Editor and Reader before 2025.2.1 allow signature spoofing via OCG
7.5
CVSS
0.3%
EPSS
No
On KEV
Description
Foxit PDF Editor and Reader before 2025.2.1 allow signature spoofing via OCG. When Optional Content Groups (OCG) are supported, the state property of an OCG is runtime-only and not included in the digital signature computation buffer. An attacker can leverage JavaScript or PDF triggers to dynamically change the visibility of OCG content after signing (Post-Sign), allowing the visual content of a signed PDF to be modified without invalidating the signature. This may result in a mismatch between the signed content and what the signer or verifier sees, undermining the trustworthiness of the digital signature. The fixed versions are 2025.2.1, 14.0.1, and 13.2.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 24% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PE
Pdf Editor · Foxit
through 13.2.0.63256; 2023.1.0.55583 through 2023.3.0.63083; 2024.1.0.63682 through 2024.4.1.66479; 14.0.0.68868; 2025.1.0.66692; 2025.2.0.68868; +6 more · source: NVD
PR
Pdf Reader · Foxit
through 2025.2.0.68868; through 2025.2.0.33046 · source: NVD
Affected product
PE
Pdf Editor
Foxit
More from Pdf Editor
9.8
CVE-2022-28104
Foxit PDF Editor v11.3.1 was discovered to contain an arbitrary file upload vulnerability
9.8
CVE-2022-24955
Foxit PDF Reader before 11.2.1 and Foxit PDF Editor before 11.2.1 have an Uncontrolled Search Path Element for DLL files
9.8
CVE-2022-24954
Foxit PDF Reader before 11.2.1 and Foxit PDF Editor before 11.2.1 have a Stack-Based Buffer Overflow related to XFA, for the 'subform colSpan="-2"' and 'draw colSpan="1"'…
8.8
CVE-2026-91800
Foxit PDF Editor installer local privilege escalation
8.8
CVE-2025-13941
Foxit PDF Reader Update Service Incorrect Permission Assignment Local Privilege Escalation Vulnerability