Medium severity · published Sep 5, 2025
CVE-2025-58352
Weblate is a web based localization tool
6.5
CVSS
0.3%
EPSS
No
On KEV
Description
Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 21% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WE
Weblate · Weblate
before 5.13.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-58352
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-58352
Patch
https://github.com/WeblateOrg/weblate/commit/0b46fe596231dd456283ead66699ae5516f23908
Issue Tracking
https://github.com/WeblateOrg/weblate/pull/16002
Vendor Advisory
https://github.com/WeblateOrg/weblate/security/advisories/GHSA-377j-wj38-4728
More from Weblate
9.8
CVE-2025-64725
Weblate has improper validation upon invitation acceptance
9.1
CVE-2026-24126
Weblate has an argument injection in management console
9.1
CVE-2025-68398
Weblate has git config file overwrite vulnerability that leads to remote code execution
8.8
CVE-2026-34393
Weblate: Privilege escalation in the user API endpoint
8.8
CVE-2022-23915
The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories
