Medium severity · published Aug 29, 2025
CVE-2025-58066
DoS Vulnerability in ntpd-rs
5.3
CVSS
0.3%
EPSS
No
On KEV
Description
nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 26% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NT
ntpd-rs · pendulum-project
>= 1.2.0, < 1.6.2 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-58066
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-58066
github.com
https://github.com/pendulum-project/ntpd-rs/commit/da37cf167736cbd4d7804b1ed7ceb572468298e0
github.com
https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-4855-q42w-5vr4
More from ntpd-rs
7.5
CVE-2026-26076
ntpd-rs affected by excessive CPU load from malformed packets
