High severity · published Jun 11, 2025
CVE-2025-5687
A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root
7.8
CVSS
0.1%
EPSS
No
On KEV
Description
A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root.
*This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.1% · higher than 2% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VP
Vpn · Mozilla
before 2.28.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-5687
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-5687
Permissions Required
https://bugzilla.mozilla.org/show_bug.cgi?id=1953736
Vendor Advisory
https://www.mozilla.org/security/advisories/mfsa2025-48/
More from Vpn
7.8
CVE-2022-0517
Mozilla VPN can load an OpenSSL configuration file from an unsecured directory
7.6
CVE-2020-15679
An OAuth session fixation vulnerability existed in the VPN login flow, where an attacker could craft a custom login URL, convince a VPN user to login via that URL, and obtain…
5.5
CVE-2023-4104
An invalid Polkit Authentication check and missing authentication requirements for D-Bus methods allowed any local user to configure arbitrary VPN setups
