High severity · published Jun 19, 2025
CVE-2025-49763
ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted
7.5
CVSS
0.7%
EPSS
No
On KEV
Description
ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted.
Users can use a new setting for the plugin (--max-inclusion-depth) to limit it.
This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10.
Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 54% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TS
Traffic Server · Apache
9.0.0 before 9.2.11; 10.0.0 before 10.0.6 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-49763
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-49763
Mailing List
https://lists.apache.org/thread/15t32nxbypqg1m2smp640vjx89o6v5f8
More from Traffic Server
10.0
CVE-2026-58162
Apache Traffic Server: Certifier plugin trusts client SNI when generating certificates
10.0
CVE-2026-58150
Apache Traffic Server: HTTP/2 requests with Transfer-Encoding are not rejected, allowing request smuggling
10.0
CVE-2026-57834
Apache Traffic Server: Malformed chunked message body allows request smuggling
9.8
CVE-2026-58185
Apache Traffic Server: Use-after-free in the intercept plugin
9.8
CVE-2026-58179
Apache Traffic Server: regex_remap plugin overflows the stack from attacker input
