Low severity · published May 27, 2025
CVE-2025-48370
auth-js Vulnerable to Insecure Path Routing from Malformed User Input
2.7
CVSS
0.9%
EPSS
No
On KEV
Description
auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 60% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AU
auth-js · supabase
< 2.70.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-48370
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-48370
github.com
https://github.com/supabase/auth-js/commit/1bcb76e479e51cd9bca2d7732d0bf3199e07a693
github.com
https://github.com/supabase/auth-js/pull/1063
github.com
https://github.com/supabase/auth-js/security/advisories/GHSA-8r88-6cj9-9fh5
