Medium severity · published Jun 24, 2025
CVE-2025-47943
Gogs stored XSS in PDF renderer
6.3
CVSS
0.4%
EPSS
No
On KEV
Description
Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
High
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 34% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
GO
gogs · gogs
<= 0.14.0+dev · source: vendor
Affected product
GO
gogs
gogs
More from gogs
8.8
CVE-2025-8110
File overwrite in file update API in Gogs
10.0
CVE-2026-52813
Gogs: Path Traversal in organization name results in RCE through Git hooks
9.9
CVE-2026-52806
Gogs: RCE via git rebase --exec argument injection in pull request merge
9.9
CVE-2024-39930
The built-in SSH server of Gogs through 0.13.0 allows argument injection in internal/ssh/ssh.go, leading to remote code execution
9.9
CVE-2024-39931
Gogs through 0.13.0 allows deletion of internal files