Critical severity · published Aug 27, 2025
CVE-2025-34522
Arcserve UDP < 10.2 Pre-Authentication Heap Overflow
9.8
CVSS
0.6%
EPSS
No
On KEV
Description
A heap-based buffer overflow vulnerability exists in the input parsing logic of Arcserve Unified Data Protection (UDP). This flaw can be triggered without authentication by sending specially crafted input to the target system. Improper bounds checking allows an attacker to overwrite heap memory, potentially leading to application crashes or remote code execution. Exploitation occurs in the context of the affected process and does not require user interaction. The vulnerability poses a high risk due to its pre-authentication nature and potential for full compromise. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 46% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
UD
Unified Data Protection (UDP) · Arcserve
8.0 through 10.1; through 7.* · source: vendor
UD
Udp · Arcserve
before 7.0; 8.0 before 10.2; 7.0; 7.0; 7.0 · source: NVD
Affected product
UD
Unified Data Protection (UDP)
Arcserve
More from Unified Data Protection (UDP)
9.1
CVE-2015-4068
Arcserve Unified Data Protection (UDP) Directory Traversal Vulnerability
9.8
CVE-2025-34520
Arcserve UDP < 10.2 Authentication Bypass
9.8
CVE-2025-34523
Arcserve UDP < 10.2 Pre-Authentication Heap Overflow
5.4
CVE-2025-34521
Arcserve UDP < 10.2 Reflected Cross-Site Scripting (XSS)