High severity · published Mar 27, 2025
CVE-2025-30067
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin
7.2
CVSS
0.9%
EPSS
No
On KEV
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin.
If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.
This issue affects Apache Kylin: from 4.0.0 through 5.0.1.
Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 60% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
KY
Kylin · Apache
4.0.0 before 5.0.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-30067
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-30067
Mailing List
https://lists.apache.org/thread/6j19pt8yoqfphf1lprtrzoqkvz1gwbnc
Mailing List
http://www.openwall.com/lists/oss-security/2025/03/27/4
More from Kylin
8.8
CVE-2020-1956
Apache Kylin OS Command Injection Vulnerability
9.8
CVE-2026-62392
Apache Kylin: OS Command Injection via Async Query API
9.8
CVE-2026-62390
Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
9.8
CVE-2022-44621
Diagnosis Controller miss parameter validation, so user may attacked by command injection via HTTP Request
9.8
CVE-2022-24697
Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters
