Medium severity · published Mar 13, 2025
CVE-2025-29768
Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted zip files in versions prior to 9.1.1198
4.4
CVSS
0.4%
EPSS
No
On KEV
Description
Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted zip files in versions prior to 9.1.1198. The impact is medium because a user must be made to view such an archive with Vim and then press 'x' on such a strange filename. The issue has been fixed as of Vim patch v9.1.1198.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 33% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BO
Bootstrap OS · Netapp
All versions, or not specified · source: NVD
VI
Vim · Vim
before 9.1.1198 · source: NVD
Affected product
BO
Bootstrap OS
Netapp
More from Bootstrap OS
9.8
CVE-2025-24813
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
7.8
CVE-2024-1086
Use-after-free in Linux kernel's netfilter: nf_tables component
7.8
CVE-2023-4911
Glibc: buffer overflow in ld.so leading to privilege escalation
7.8
CVE-2022-0492
Linux Kernel Improper Authentication Vulnerability
9.8
CVE-2024-56337
Apache Tomcat: RCE due to TOCTOU issue in JSP compilation - CVE-2024-50379 mitigation was incomplete