High severity · published Feb 4, 2025
CVE-2025-23015
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra
8.8
CVSS
1%
EPSS
No
On KEV
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 63% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CA
Cassandra · Apache
3.0.0 before 3.0.31; 3.1 before 3.11.18; 4.0.0 before 4.0.16; 4.1.0 before 4.1.8; 5.0.0 before 5.0.3 · source: NVD
Affected product
CA
Cassandra
Apache
More from Cassandra
9.8
CVE-2016-3427
Oracle Java SE and JRockit Unspecified Vulnerability
9.8
CVE-2018-8016
The default configuration in Apache Cassandra 3.8 through 3.11.1 binds an unauthenticated JMX/RMI interface to all network interfaces, which allows remote attackers to execute…
9.1
CVE-2021-44521
When running Apache Cassandra with the following configuration: enable_user_defined_functions: true enable_scripted_user_defined_functions: true…
8.8
CVE-2026-27314
Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
8.8
CVE-2025-26467
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra