Medium severity · published Jan 6, 2025
CVE-2025-21617
Guzzle OAuth Subscriber has insufficient nonce entropy
6.3
CVSS
0.5%
EPSS
No
On KEV
Description
Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OA
oauth-subscriber · guzzle
< 0.8.1 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-21617
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-21617
github.com
https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192
github.com
https://github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53
github.com
https://github.com/guzzle/oauth-subscriber/releases/tag/0.8.1
github.com
https://github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88
