High severity · published Oct 24, 2025
CVE-2025-10861
Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers <= 2.1.4 - Unauthenticated Server-Side Request Forgery
7.5
CVSS
0.4%
EPSS
No
On KEV
Description
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 32% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PB
Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers · roxnor
through 2.1.4 · source: vendor
Affected product
PB
Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers
roxnor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-10861
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-10861
plugins.trac.wordpress.org
https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.2/includes/Routes/FetchDemo.php#L15
plugins.trac.wordpress.org
https://plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.2/includes/Routes/FetchDemo.php#L35
plugins.trac.wordpress.org
https://plugins.trac.wordpress.org/changeset/3369146/
plugins.trac.wordpress.org
https://plugins.trac.wordpress.org/changeset/3379308/
www.wordfence.com
https://www.wordfence.com/threat-intel/vulnerabilities/id/5f4767b5-5dd6-4a2a-b44a-5297432286b1?source=cve
More from Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers
8.2
CVE-2025-13192
Popup builder with Gamification <= 2.2.0 - Unauthenticated SQL Injection via Multiple REST API Endpoints
7.5
CVE-2025-10862
Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers <= 2.1.3 - Unauthenticated SQL Injection via 'id'
5.4
CVE-2025-14895
PopupKit <= 2.2.0 - Missing Authorization to Sensitive Information Disclosure and Data Deletion
4.3
CVE-2025-14441
Popupkit <= 2.2.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Subscriber Data Deletion
