Critical severity · published Sep 10, 2025
CVE-2025-10226
PostgreSQL Upgrade from v10 to v17.4 in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier to Address Multiple Vulnerabilities
9.8
CVSS
0.6%
EPSS
No
On KEV
Description
Dependency on Vulnerable Third-Party Component (CWE-1395) in the PostgreSQL backend in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier on Windows and Linux allows a remote attacker to escalate privileges, execute arbitrary code, or cause denial-of-service via exploitation of multiple known CVEs present in PostgreSQL v10.x, which are resolved in PostgreSQL 17.4.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AC
AxxonOne C-Werk · AxxonSoft
through 2.0.8 · source: vendor
AO
Axxon One · Axxonsoft
through 2.0.8 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-10226
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-10226
Vendor Advisory
https://www.axxonsoft.com/legal/axxonsoft-vulnerability-disclosure-policy/security-advisories
Release Notes
https://www.postgresql.org/docs/release
More from AxxonOne C-Werk
9.8
CVE-2025-10220
Outdated Third-Party NuGet Packages in AxxonSoft Axxon One VMS 2.0.0 through 2.0.4
8.1
CVE-2025-10223
Improper Session Cleanup on Role Removal in Web Admin Panel in AxxonSoft Axxon One (C-Werk)
7.5
CVE-2025-10225
Incorrect Memory Allocation in OpenSSL-Based Session Module in AxxonSoft Axxon One (C-Werk)
7.1
CVE-2025-10224
Incorrect Evaluation of LDAP Nested Groups during Login in AxxonSoft Axxon One (C-Werk)
4.6
CVE-2025-10227
Lack of Encryption in Object Archive in AxxonSoft Axxon One (C-Werk) before 2.0.8
