High severity · published Aug 12, 2024
CVE-2024-7272
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5
8.8
CVSS
1.2%
EPSS
No
On KEV
Description
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 68% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FF
Ffmpeg · Ffmpeg
before 5.1.6 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-7272
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-7272
Product
https://ffmpeg.org/
Exploit
https://github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc5
Not Applicable
https://github.com/CookedMelon/ReportCVE/tree/main/FFmpeg/poc6
Permissions Required
https://vuldb.com/?ctiid.273945
Permissions Required
https://vuldb.com/?id.273945
More from Ffmpeg
9.8
CVE-2026-75143
FFmpeg Heap Buffer Overflow via RIST Protocol Reader
9.8
CVE-2026-40962
FFmpeg before 8.1 has an integer overflow and resultant out-of-bounds write via CENC (Common Encryption) subsample data to libavformat/mov.c
9.8
CVE-2024-35368
FFmpeg n7.0 is affected by a Double Free via the rkmpp_retrieve_frame function within libavcodec/rkmppdec.c
9.8
CVE-2024-31581
FFmpeg version n6.1 was discovered to contain an improper validation of array index vulnerability in libavcodec/cbs_h266_syntax_template.c
9.8
CVE-2024-22862
Integer overflow vulnerability in FFmpeg before n6.1, allows remote attackers to execute arbitrary code via the JJPEG XL Parser
