High severity · published Jan 2, 2025
CVE-2024-56034
WordPress Services updates for customers plugin <= 1.0 - Reflected Cross Site Scripting (XSS) vulnerability
7.1
CVSS
0.3%
EPSS
No
On KEV
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Irshad A.Khan Services updates for customers service-updates-for-customers allows Reflected XSS.This issue affects Services updates for customers: from n/a through <= 1.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 19% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SU
Services updates for customers · Irshad A.Khan
through 1.0 · source: vendor
Affected product
SU
Services updates for customers
Irshad A.Khan
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-56034
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-56034
patchstack.com
https://patchstack.com/database/Wordpress/Plugin/service-updates-for-customers/vulnerability/wordpress-services-updates-for-customers-plugin-1-0-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
