Low severity · published Nov 22, 2024
CVE-2024-45719
Inadequate Encryption Strength vulnerability in Apache Answer
2.6
CVSS
0.2%
EPSS
No
On KEV
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.0.
The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable.
Users are recommended to upgrade to version 1.4.1, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
High
User interaction
Required
Confidentiality
Low
Integrity
None
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 16% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AN
Answer · Apache
before 1.4.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-45719
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-45719
Mailing List
https://lists.apache.org/thread/sz2d0z39k01nbx3r9pj65t76o1hy9491
Mailing List
http://www.openwall.com/lists/oss-security/2024/11/22/1
More from Answer
9.1
CVE-2026-60053
Apache Answer: Residual Administrative API Key Access After Role or Account Revocation
9.1
CVE-2024-22393
Unrestricted Upload of File with Dangerous Type vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1
7.5
CVE-2026-60023
Apache Answer: Unauthorized disclosure of deleted or pending answer content
7.5
CVE-2026-48911
Apache Answer: Unauthenticated OAuth Email-Binding Account Takeover via Existing User Confirmation Flow
7.5
CVE-2026-48834
Apache Answer: Denial of service via crafted Accept-Language header parsing
