Critical severity · published Sep 10, 2024
CVE-2024-45409
The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector
9.8
CVSS
10.7%
EPSS
No
On KEV
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)10.7% · higher than 96% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
GI
GitLab · GitLab
before 16.11.10; 17.0.0 before 17.0.8; 17.1.0 before 17.1.8; 17.2.0 before 17.2.7; 17.3.0 before 17.3.3 · source: NVD
RU
ruby-saml · SAML-Toolkits
< 1.12.3; >= 1.13.0, < 1.17.0 · source: vendor, NVD, CISA
OS
Omniauth Saml · Omniauth
through 1.10.3; 2.0.0; 2.1.0 · source: NVD
OM
Omniauth-saml · Omniauth
through 2.1.0 · source: CISA