Medium severity · published Sep 2, 2024
CVE-2024-45312
Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf
5.3
CVSS
0.5%
EPSS
No
On KEV
Description
Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 41% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OV
overleaf · overleaf
>= 4.0.0, < 4.2.7; >= 5.0.0, < 5.0.7 · source: vendor, NVD, CISA
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-45312
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-45312
Patch
https://github.com/overleaf/overleaf/commit/b5e5d39c3ad4e7763d42b837738955f8ded4dcd3
Vendor Advisory
https://github.com/overleaf/overleaf/security/advisories/GHSA-pxm4-p454-vppg
Product
https://github.com/overleaf/toolkit
More from overleaf
5.4
CVE-2024-45313
Insecure default setting for Server Pro installed via Overleaf toolkit
