Medium severity · published Aug 16, 2024
CVE-2024-43374
The UNIX editor Vim prior to version 9.1.0678 has a use-after-free error in argument list handling
4.7
CVSS
0.4%
EPSS
No
On KEV
Description
The UNIX editor Vim prior to version 9.1.0678 has a use-after-free error in argument list handling. When adding a new file to the argument list, this triggers `Buf*` autocommands. If in such an autocommand the buffer that was just opened is closed (including the window where it is shown), this causes the window structure to be freed which contains a reference to the argument list that we are actually modifying. Once the autocommands are completed, the references to the window and argument list are no longer valid and as such cause an use-after-free. Impact is low since the user must either intentionally add some unusual autocommands that wipe a buffer during creation (either manually or by sourcing a malicious plugin), but it will crash Vim. The issue has been fixed as of Vim patch v9.1.0678.
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Local
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 29% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BO
Bootstrap OS · Netapp
All versions, or not specified · source: NVD
NE
Neovim · Neovim
through 0.10.4 · source: NVD
VI
Vim · Vim
before 9.1.0678 · source: NVD
Affected product
NE
Neovim
Neovim
More from Neovim
8.6
CVE-2019-12735
getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by…
7.8
CVE-2023-5535
Use After Free in GitHub repository vim/vim prior to v9.0.2010
7.8
CVE-2023-4781
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1873
7.8
CVE-2023-4752
Use After Free in GitHub repository vim/vim prior to 9.0.1858
7.8
CVE-2023-4750
Use After Free in GitHub repository vim/vim prior to 9.0.1857