Low severity · published Apr 30, 2024
CVE-2024-4327
Apryse WebViewer PDF Document cross site scripting
3.5
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability was found in Apryse WebViewer up to 10.8.0. It has been classified as problematic. This affects an unknown part of the component PDF Document Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 10.9 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-262419. NOTE: The vendor was contacted early about this disclosure and explains that the documentation recommends a strict Content Security Policy and the issue was fixed in release 10.9.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 40% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WE
WebViewer · Apryse
10.0; 10.1; 10.2; 10.3; 10.4; 10.5; +3 more · source: vendor, CISA
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-4327
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-4327
1drv.ms
https://1drv.ms/b/s!AqJ7dHWS4CD_l0acw2hDjgo-C2zC?e=DOGPmq
docs.apryse.com
https://docs.apryse.com/documentation/web/faq/content-security-policy/#recommended-policy
vuldb.com
https://vuldb.com/?ctiid.262419
vuldb.com
https://vuldb.com/?id.262419
vuldb.com
https://vuldb.com/?submit.321231
More from WebViewer
5.4
CVE-2024-57240
A Cross-Site Scripting (XSS) vulnerability in the Rendering Engine component in Apryse WebViewer v11.1 and earlier allows attackers to execute arbitrary code via a crafted PDF…
