High severity · published Sep 3, 2025
CVE-2024-43115
Improper Input Validation vulnerability in Apache DolphinScheduler
8.8
CVSS
0.6%
EPSS
No
On KEV
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script.
This issue affects Apache DolphinScheduler: before 3.2.2.
Users are recommended to upgrade to version 3.3.1, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 48% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DO
Dolphinscheduler · Apache
before 3.2.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-43115
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-43115
Mailing List
https://lists.apache.org/thread/qm36nrsv1vrr2j4o5q2wo75h3686hrnj
www.openwall.com
http://www.openwall.com/lists/oss-security/2025/09/03/1
More from Dolphinscheduler
9.8
CVE-2026-32966
Apache DolphinScheduler: DataSource API Missing Authorization Check Leads to Arbitrary Data Source Metadata Disclosure
9.8
CVE-2024-43166
Incorrect Default Permissions vulnerability in Apache DolphinScheduler
9.8
CVE-2024-43202
Exposure of Remote Code Execution in Apache Dolphinscheduler
9.8
CVE-2023-49109
Exposure of Remote Code Execution in Apache Dolphinscheduler
9.8
CVE-2022-45875
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability
