High severity · published Jul 29, 2024
CVE-2024-41817
ImageMagick is a free and open-source software suite, used for editing and manipulating digital images
7.8
CVSS
0.9%
EPSS
No
On KEV
Description
ImageMagick is a free and open-source software suite, used for editing and manipulating digital images. The `AppImage` version `ImageMagick` might use an empty path when setting `MAGICK_CONFIGURE_PATH` and `LD_LIBRARY_PATH` environment variables while executing, which might lead to arbitrary code execution by loading malicious configuration files or shared libraries in the current working directory while executing `ImageMagick`. The vulnerability is fixed in 7.11-36.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 61% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
IM
Imagemagick · Imagemagick
7.0.11-13 before 7.1.1-36 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-41817
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-41817
Issue Tracking
https://github.com/ImageMagick/ImageMagick/blob/3b22378a23d59d7517c43b65b1822f023df357a0/app-image/AppRun#L11-L14
Patch
https://github.com/ImageMagick/ImageMagick/commit/6526a2b28510ead6a3e14de711bb991ad9abff38
Exploit
https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8rxc-922v-phg8
More from Imagemagick
8.4
CVE-2016-3714
ImageMagick Improper Input Validation Vulnerability
5.5
CVE-2016-3715
ImageMagick Arbitrary File Deletion Vulnerability
5.5
CVE-2016-3718
ImageMagick Server-Side Request Forgery (SSRF) Vulnerability
9.8
CVE-2026-25986
ImageMagick has a heap buffer overflow in YUV 4:2:2 decoder
9.8
CVE-2026-25983
ImageMagick has Use After Free in MSLStartElement in "coders/msl.c"
