High severity · published Mar 17, 2025
CVE-2024-40635
containerd is an open-source container runtime
7.8
CVSS
0.3%
EPSS
No
On KEV
Description
containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 23% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CO
Containerd · Linuxfoundation
before 1.6.38; 1.7.0 before 1.7.27; 2.0.0 before 2.0.4 · source: NVD
DL
Debian Linux · Debian
11.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-40635
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-40635
Patch
https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da
Patch
https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20
Patch
https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a
Vendor Advisory
https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg
Mailing List
https://lists.debian.org/debian-lts-announce/2025/05/msg00005.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
