High severity · published Nov 14, 2024
CVE-2024-38479
Improper Input Validation vulnerability in Apache Traffic Server
7.5
CVSS
0.8%
EPSS
No
On KEV
Description
Improper Input Validation vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.5. Users are recommended to upgrade to version 9.2.6, which fixes the issue, or 10.0.2, which does not have the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 57% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TS
Traffic Server · Apache
8.0.0 through 8.1.11; 9.0.0 before 9.2.6 · source: NVD
Affected product
TS
Traffic Server
Apache
More from Traffic Server
10.0
CVE-2026-58162
Apache Traffic Server: Certifier plugin trusts client SNI when generating certificates
10.0
CVE-2026-58150
Apache Traffic Server: HTTP/2 requests with Transfer-Encoding are not rejected, allowing request smuggling
10.0
CVE-2026-57834
Apache Traffic Server: Malformed chunked message body allows request smuggling
9.8
CVE-2026-58185
Apache Traffic Server: Use-after-free in the intercept plugin
9.8
CVE-2026-58179
Apache Traffic Server: regex_remap plugin overflows the stack from attacker input