High severity · published Jul 1, 2024
CVE-2024-38477
null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request
7.5
CVSS
3.2%
EPSS
No
On KEV
Description
null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.2% · higher than 88% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
HS
HTTP Server · Apache
2.4.0 before 2.4.60 · source: NVD
CD
Clustered Data Ontap · Netapp
9.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-38477
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-38477
Vendor Advisory
https://httpd.apache.org/security/vulnerabilities_24.html
Third Party Advisory
https://security.netapp.com/advisory/ntap-20240712-0001/
seclists.org
http://seclists.org/fulldisclosure/2024/Oct/11
www.openwall.com
http://www.openwall.com/lists/oss-security/2024/07/01/10
More from HTTP Server
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
9.8
CVE-2021-41773
Path traversal and file disclosure vulnerability in Apache HTTP Server 2.4.49
9.1
CVE-2024-38475
Apache HTTP Server weakness in mod_rewrite when first segment of substitution matches filesystem path.
9.0
CVE-2021-40438
mod_proxy SSRF
7.8
CVE-2019-0211
Apache HTTP Server Privilege Escalation Vulnerability
