High severity · published Nov 7, 2024
CVE-2024-38286
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat
7.5
CVSS
1.7%
EPSS
No
On KEV
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.13 through 9.0.89.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.35 through 8.5.100 and 7.0.92 through 7.0.109. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M21, 10.1.25, or 9.0.90, which fixes the issue.
Apache Tomcat, under certain configurations on any platform, allows an attacker to cause an OutOfMemoryError by abusing the TLS handshake process.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.7% · higher than 77% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TO
Tomcat · Apache
9.0.13 before 9.0.90; 10.1.1 before 10.1.25; 10.1.0; 10.1.0; 10.1.0; 10.1.0; +34 more · source: NVD
OT
Ontap Tools · Netapp
9; 10 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-38286
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-38286
Mailing List
https://lists.apache.org/thread/wms60cvbsz3fpbz9psxtfx8r41jl6d4s
Mailing List
http://www.openwall.com/lists/oss-security/2024/09/23/2
lists.debian.org
https://lists.debian.org/debian-lts-announce/2025/01/msg00009.html
Third Party Advisory
https://security.netapp.com/advisory/ntap-20241101-0010/
More from Tomcat
9.8
CVE-2025-24813
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
9.8
CVE-2020-1938
Apache Tomcat Improper Privilege Management Vulnerability
9.8
CVE-2016-8735
Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if…
8.1
CVE-2017-12617
When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g
8.1
CVE-2017-12615
When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g
