High severity · published May 14, 2024
CVE-2024-32465
Git is a revision control system
7.8
CVSS
1%
EPSS
No
On KEV
Description
Git is a revision control system. The Git project recommends to avoid working in untrusted repositories, and instead to clone it first with `git clone --no-local` to obtain a clean copy. Git has specific protections to make that a safe operation even with an untrusted source repository, but vulnerabilities allow those protections to be bypassed. In the context of cloning local repositories owned by other users, this vulnerability has been covered in CVE-2024-32004. But there are circumstances where the fixes for CVE-2024-32004 are not enough: For example, when obtaining a `.zip` file containing a full copy of a Git repository, it should not be trusted by default to be safe, as e.g. hooks could be configured to run within the context of that repository. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid using Git in repositories that have been obtained via archives from untrusted sources.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 63% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0; 11.0 · source: NVD
FE
Fedora · Fedoraproject
40 · source: NVD
GI
Git · Git-scm
before 2.39.4; 2.40.0 before 2.40.2; 2.42.0 before 2.42.2; 2.43.0 before 2.43.4; 2.41.0; 2.44.0; +1 more · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-32465
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-32465
Mailing List
http://www.openwall.com/lists/oss-security/2024/05/14/2
Technical Description
https://git-scm.com/docs/git#_security
Technical Description
https://git-scm.com/docs/git-clone
Patch
https://github.com/git/git/commit/7b70e9efb18c2cc3f219af399bd384c5801ba1d7
Vendor Advisory
https://github.com/git/git/security/advisories/GHSA-vm9j-46j9-qvq4
Mailing List
https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
