Critical severity · published Apr 2, 2024
CVE-2024-3203
c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow
9.8
CVSS
1.4%
EPSS
No
On KEV
Description
A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.4% · higher than 72% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CB
c-blosc2 ·
2.13.0; 2.13.1; 2.13.2 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-3203
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-3203
Product
https://drive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharing
Release Notes
https://github.com/Blosc/c-blosc2/releases/tag/v2.14.3
Permissions Required
https://vuldb.com/?ctiid.259050
Third Party Advisory
https://vuldb.com/?id.259050
Exploit
https://vuldb.com/?submit.304556
More from c-blosc2
9.8
CVE-2024-3204
c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow
