Low severity · published Apr 4, 2024
CVE-2024-30261
Undici is an HTTP/1.1 client, written from scratch for Node.js
3.5
CVSS
0.8%
EPSS
No
On KEV
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. An attacker can alter the `integrity` option passed to `fetch()`, allowing `fetch()` to accept requests as valid even if they have been tampered. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 57% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FE
Fedora · Fedoraproject
38; 39; 40 · source: NVD
UN
Undici · Nodejs
before 5.28.4; 6.0.0 before 6.11.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-30261
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-30261
Patch
https://github.com/nodejs/undici/commit/2b39440bd9ded841c93dd72138f3b1763ae26055
Patch
https://github.com/nodejs/undici/commit/d542b8cd39ec1ba303f038ea26098c3f355974f3
Vendor Advisory
https://github.com/nodejs/undici/security/advisories/GHSA-9qxr-qj54-h672
Exploit
https://hackerone.com/reports/2377760
Product
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33/
Product
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ/
More from Fedora
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2024-4577
Argument Injection in PHP-CGI
9.8
CVE-2021-44026
Roundcube Webmail SQL Injection Vulnerability
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
