Medium severity · published Apr 4, 2024
CVE-2024-30260
Undici is an HTTP/1.1 client, written from scratch for Node.js
4.3
CVSS
0.7%
EPSS
No
On KEV
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici cleared Authorization and Proxy-Authorization headers for `fetch()`, but did not clear them for `undici.request()`. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 54% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FE
Fedora · Fedoraproject
38; 39; 40 · source: NVD
UN
Undici · Nodejs
before 5.28.4; 6.0.0 before 6.11.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-30260
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-30260
Patch
https://github.com/nodejs/undici/commit/64e3402da4e032e68de46acb52800c9a06aaea3f
Patch
https://github.com/nodejs/undici/commit/6805746680d27a5369d7fb67bc05f95a28247d75
Patch
https://github.com/nodejs/undici/security/advisories/GHSA-m4v8-wqvr-p9f7
Product
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33/
Product
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ/
Product
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/P6Q4RGETHVYVHDIQGTJGU5AV6NJEI67E/
More from Fedora
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2024-4577
Argument Injection in PHP-CGI
9.8
CVE-2021-44026
Roundcube Webmail SQL Injection Vulnerability
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
