Medium severity · published Mar 12, 2024
CVE-2024-28098
The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings
5.4
CVSS
1.7%
EPSS
No
On KEV
Description
The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role.
This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0.
2.10 Apache Pulsar users should upgrade to at least 2.10.6.
2.11 Apache Pulsar users should upgrade to at least 2.11.4.
3.0 Apache Pulsar users should upgrade to at least 3.0.3.
3.1 Apache Pulsar users should upgrade to at least 3.1.3.
3.2 Apache Pulsar users should upgrade to at least 3.2.1.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.7% · higher than 77% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PU
Pulsar · Apache
2.7.1 before 2.10.6; 2.11.0 before 2.11.4; 3.0.0 before 3.0.3; 3.1.0 before 3.1.3; 3.2.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-28098
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-28098
Mailing List
http://www.openwall.com/lists/oss-security/2024/03/12/12
Vendor Advisory
https://lists.apache.org/thread/3m6923y3wxpdcs9346sjvt8ql9swqc2z
Vendor Advisory
https://pulsar.apache.org/security/CVE-2024-28098/
More from Pulsar
9.9
CVE-2024-27317
In Pulsar Functions Worker, authenticated users can upload functions in jar or nar files
9.9
CVE-2024-27135
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the…
9.8
CVE-2021-22160
If Apache Pulsar is configured to authenticate clients using tokens based on JSON Web Tokens (JWT), the signature of the token is not validated if the algorithm of the presented…
8.8
CVE-2024-27894
The Pulsar Functions Worker includes a capability that permits authenticated users to create functions where the function's implementation is referenced by a URL
8.8
CVE-2023-30429
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar
