Medium severity · published Feb 4, 2025
CVE-2024-27137
In Apache Cassandra it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a…
5.3
CVSS
0.3%
EPSS
No
On KEV
Description
In Apache Cassandra it is possible for a local attacker without access
to the Apache Cassandra process or configuration files to manipulate
the RMI registry to perform a man-in-the-middle attack and capture user
names and passwords used to access the JMX interface. The attacker can
then use these credentials to access the JMX interface and perform
unauthorized operations.
This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10.
This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11.
Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 21% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CA
Cassandra · Apache
4.0.2 before 4.0.15; 4.1.0 before 4.1.8; after 5.0.0 before 5.0.3; 5.0.0; 5.0.0; 5.0.0; +1 more · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-27137
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-27137
Issue Tracking
https://lists.apache.org/thread/jsk87d9yv8r204mgqpz1qxtp5wcrpysm
Third Party Advisory
https://security.netapp.com/advisory/ntap-20250214-0004/
More from Cassandra
9.8
CVE-2016-3427
Oracle Java SE and JRockit Unspecified Vulnerability
9.8
CVE-2018-8016
The default configuration in Apache Cassandra 3.8 through 3.11.1 binds an unauthenticated JMX/RMI interface to all network interfaces, which allows remote attackers to execute…
9.1
CVE-2021-44521
When running Apache Cassandra with the following configuration: enable_user_defined_functions: true enable_scripted_user_defined_functions: true…
8.8
CVE-2026-27314
Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
8.8
CVE-2025-26467
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra
