High severity · published Feb 29, 2024
CVE-2024-26146
Rack is a modular Ruby web server interface
7.5
CVSS
2%
EPSS
No
On KEV
Description
Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.0% · higher than 81% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD
RA
Rack · Rack
0.4 before 2.0.9.4; 2.1.0 before 2.1.4.4; 2.2.0 before 2.2.8.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-26146
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-26146
Vendor Advisory
https://discuss.rubyonrails.org/t/possible-denial-of-service-vulnerability-in-rack-header-parsing/84942
Patch
https://github.com/rack/rack/commit/30b8e39a578b25d4bdcc082c1c52c6f164b59716
Patch
https://github.com/rack/rack/commit/6c5d90bdcec0949f7ba06db62fb740dab394b582
Patch
https://github.com/rack/rack/commit/a227cd793778c7c3a827d32808058571569cda6f
Patch
https://github.com/rack/rack/commit/e4c117749ba24a66f8ec5a08eddf68deeb425ccd
Vendor Advisory
https://github.com/rack/rack/security/advisories/GHSA-54rr-7fvw-6x8f
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
