High severity · published Feb 29, 2024
CVE-2024-26141
Rack is a modular Ruby web server interface
7.5
CVSS
1.6%
EPSS
No
On KEV
Description
Rack is a modular Ruby web server interface. Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the `Rack::File` middleware or the `Rack::Utils.byte_ranges` methods (this includes Rails applications). The vulnerability is fixed in 3.0.9.1 and 2.2.8.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.6% · higher than 76% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD
RA
Rack · Rack
1.3.0 before 2.2.8.1; 3.0.0 before 3.0.9.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-26141
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-26141
Exploit
https://discuss.rubyonrails.org/t/possible-dos-vulnerability-with-range-header-in-rack/84944
Patch
https://github.com/rack/rack/commit/4849132bef471adb21131980df745f4bb84de2d9
Patch
https://github.com/rack/rack/commit/62457686b26d33a15a254c7768c2076e8e02b48b
Exploit
https://github.com/rack/rack/security/advisories/GHSA-xj5v-6v4g-jfw6
Exploit
https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26141.yml
Mailing List
https://lists.debian.org/debian-lts-announce/2024/04/msg00022.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
