Medium severity · published Feb 13, 2024
CVE-2024-25119
TYPO3 is an open source PHP based web content management system released under the GNU GPL
4.9
CVSS
0.4%
EPSS
No
On KEV
Description
TYPO3 is an open source PHP based web content management system released under the GNU GPL. The plaintext value of `$GLOBALS['SYS']['encryptionKey']` was displayed in the editing forms of the TYPO3 Install Tool user interface. This allowed attackers to utilize the value to generate cryptographic hashes used for verifying the authenticity of HTTP request parameters. Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions. Users are advised to update to TYPO3 versions 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, 13.0.1 that fix the problem described. There are no known workarounds for this vulnerability.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 30% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TY
Typo3 · Typo3
8.0.0 before 8.7.57; 9.0.0 before 9.5.46; 10.0.0 before 10.4.43; 11.0.0 before 11.5.35; 12.0.0 before 12.4.11; 13.0.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-25119
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-25119
Third Party Advisory
https://github.com/TYPO3/typo3/security/advisories/GHSA-h47m-3f78-qp9g
Vendor Advisory
https://typo3.org/security/advisory/typo3-core-sa-2024-004
More from Typo3
10.0
CVE-2020-11066
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.17 and greater than or equal to 10.0.0 and less than 10.4.2, calling unserialize() on malicious user-submitted…
9.8
CVE-2024-45233
An issue was discovered in powermail extension through 12.3.5 for TYPO3
9.8
CVE-2011-3583
It was found that Typo3 Core versions 4.5.0 - 4.5.5 uses prepared statements that, if the parameter values are not properly replaced, could lead to a SQL Injection vulnerability
9.8
CVE-2011-4628
TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request
8.8
CVE-2025-59017
Broken Access Control in Backend AJAX Routes
