Medium severity · published Mar 13, 2024
CVE-2024-23672
Denial of Service via incomplete cleanup vulnerability in Apache Tomcat
6.3
CVSS
2.3%
EPSS
No
On KEV
Description
Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98.
Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.3% · higher than 83% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TO
Tomcat · Apache
8.5.0 before 8.5.99; 9.0.0 before 9.0.86; 10.1.0 before 10.1.19; 11.0.0; 11.0.0; 11.0.0; +13 more · source: NVD
DL
Debian Linux · Debian
10.0 · source: NVD
FE
Fedora · Fedoraproject
39; 40 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-23672
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-23672
Vendor Advisory
https://lists.apache.org/thread/cmpswfx6tj4s7x0nxxosvfqs11lvdx2f
Mailing List
http://www.openwall.com/lists/oss-security/2024/03/13/4
Mailing List
https://lists.debian.org/debian-lts-announce/2024/04/msg00001.html
Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B/
Third Party Advisory
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55/
Third Party Advisory
https://security.netapp.com/advisory/ntap-20240402-0002/
More from Tomcat
9.8
CVE-2025-24813
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
9.8
CVE-2020-1938
Apache Tomcat Improper Privilege Management Vulnerability
9.8
CVE-2016-8735
Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if…
8.1
CVE-2017-12617
When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g
8.1
CVE-2017-12615
When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g
