Critical severity · published Nov 4, 2024
CVE-2024-23590
Session Fixation vulnerability in Apache Kylin
9.1
CVSS
0.7%
EPSS
No
On KEV
Description
Session Fixation vulnerability in Apache Kylin. This issue affects Apache Kylin: from 2.0.0 through 4.x. Users are recommended to upgrade to version 5.0.0 or above, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 52% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
KY
Kylin · Apache
2.0.0 before 5.0.0 · source: NVD
Affected product
KY
Kylin
Apache
More from Kylin
8.8
CVE-2020-1956
Apache Kylin OS Command Injection Vulnerability
9.8
CVE-2026-62392
Apache Kylin: OS Command Injection via Async Query API
9.8
CVE-2026-62390
Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
9.8
CVE-2022-44621
Diagnosis Controller miss parameter validation, so user may attacked by command injection via HTTP Request
9.8
CVE-2022-24697
Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters