Low severity · published Jan 18, 2024
CVE-2024-22403
Nextcloud server is a self hosted personal cloud system
3.7
CVSS
0.5%
EPSS
No
On KEV
Description
Nextcloud server is a self hosted personal cloud system. In affected versions OAuth codes did not expire. When an attacker would get access to an authorization code they could authenticate at any time using the code. As of version 28.0.0 OAuth codes are invalidated after 10 minutes and will no longer be authenticated. To exploit this vulnerability an attacker would need to intercept an OAuth code from a user session. It is recommended that the Nextcloud Server is upgraded to 28.0.0. There are no known workarounds for this vulnerability.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 39% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NS
Nextcloud Server · Nextcloud
before 28.0.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-22403
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-22403
Vendor Advisory
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-wppc-f5g8-vx36
Patch
https://github.com/nextcloud/server/pull/40766
Permissions Required
https://hackerone.com/reports/1784162
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/S6PN4GVJ5TZUC6WSG4X3ZA3AMPBEKNAX/
More from Nextcloud Server
9.8
CVE-2023-49792
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform
9.8
CVE-2023-48306
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform
9.8
CVE-2021-32802
Nextcloud server is an open source, self hosted personal cloud
9.8
CVE-2021-32726
Nextcloud Server is a Nextcloud package that handles data storage
9.8
CVE-2021-22915
Nextcloud server before 19.0.11, 20.0.10, 21.0.2 is vulnerable to brute force attacks due to lack of inclusion of IPv6 subnets in rate-limiting considerations
