Critical severity · published Dec 27, 2024
CVE-2024-12986
DrayTek Vigor2960/Vigor300B Web Management Interface apmcfgupptim os command injection
9.8
CVSS
35.3%
EPSS
No
On KEV
Description
A vulnerability, which was classified as critical, has been found in DrayTek Vigor2960 and Vigor300B 1.5.1.3/1.5.1.4. This issue affects some unknown processing of the file /cgi-bin/mainfunction.cgi/apmcfgupptim of the component Web Management Interface. The manipulation of the argument session leads to os command injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.1.5 is able to address this issue. It is recommended to upgrade the affected component.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)35.3% · higher than 98% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VI
Vigor2960 · DrayTek
1.5.1.3; 1.5.1.4 · source: vendor
VI
Vigor300B · DrayTek
1.5.1.3; 1.5.1.4 · source: vendor
VF
Vigor2960 Firmware · Draytek
1.5.1.3 before 1.5.1.5 · source: NVD
VF
Vigor300b Firmware · Draytek
1.5.1.3 before 1.5.1.5 · source: NVD