Medium severity · published Mar 8, 2025
CVE-2024-10326
RomethemeKit For Elementor <= 1.5.3 - Missing Authorization in save_options and reset_widgets
4.3
CVSS
0.4%
EPSS
No
On KEV
Description
The RomethemeKit For Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_options and reset_widgets functions in all versions up to, and including, 1.5.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify plugin settings or reset plugin widgets to their default state (all enabled). NOTE: This vulnerability was partially fixed in version 1.5.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 30% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
RT
RTMKit · rometheme
through 1.5.3 · source: vendor
RF
Romethemekit For Elementor · Rometheme
before 1.5.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-10326
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-10326
Patch
https://plugins.trac.wordpress.org/changeset/3220079/rometheme-for-elementor
Patch
https://plugins.trac.wordpress.org/changeset/3231792/rometheme-for-elementor
Third Party Advisory
https://www.wordfence.com/threat-intel/vulnerabilities/id/230b3f2f-44cf-46eb-8e6a-3c52f2ea2fb9?source=cve
More from RTMKit
9.9
CVE-2025-62065
WordPress RTMKit plugin <= 1.6.5 - Arbitrary File Upload vulnerability
9.9
CVE-2025-30911
WordPress RomethemeKit For Elementor plugin <= 1.5.4 - Arbitrary Plugin Installation/Activation to RCE vulnerability
8.8
CVE-2026-84752
WordPress RTMKit plugin <= 2.1.5 - PHP Object Injection vulnerability
8.8
CVE-2026-3425
RTMKit Addons for Elementor <= 2.0.2 - Authenticated (Author+) Local File Inclusion via 'path'
7.1
CVE-2026-84763
WordPress RTMKit plugin <= 2.1.5 - Cross Site Scripting (XSS) vulnerability
